1. Store
  2. Apps
  3. Hardware
  4. Support
  5. Solutions

ClearFoundation

About Me

Basic Information

Whereabouts

State / Province
PA
City / Town
Gettysburg
Country
United States

Web Links

Web Site
mychcllc.com

Connections

11 connections
  • Amir
  • Ben Chambers
  • Devin Johnson
  • Nick Howitt
  • Tim Burgess
  • Darryl Sokoloski
  • John Terpstra
  • Peter Baldwin
  • Dave Loper
  • Aaron Bylund
  • Marcos Martins
kris
kris
snow
  • Karma
  • Member since
  • Tuesday, 29 December 2009 13:16
  • Last online
  • 732 days ago
  • Profile views
  • 3259 views
Yesterday
Peter Baldwin replied to the topic Re:6.6 x64 install issue in the forums.
We seem to be having another round of blank screens in ClearOS 6.6. If possible, try changing the contents of /etc/X11/xorg.conf.d/vm.conf to:

Code:


Section "Screen"
    Identifier    "Default Screen"
    Monitor        "Configured Monitor"
    Device        "Configured Video Device"
    DefaultDepth    24
    Subsection "Display"
        Depth       24
        Modes       "800x600" "640x480"
       EndSubsection
EndSection



And then reboot.
08:05 AM
Peter Baldwin replied to the topic Re:Is the httpd service required by default in the forums.
Hello,

Httpd is not required. The web-based administration tool in ClearOS runs off a sandboxed Apache HTTP web server.
08:01 AM
Peter Baldwin replied to the topic Re:BUG - dnsmasq init script? in the forums.
It's a bug, but a cosmetic one. The $NETWORKING parameter should always be defined (in /etc/sysconfig/network) which in turn removes the requirement for the quotes. However, the Dnsmasq init script (and many others) should not assume that $NETWORKING is defined. What is in your /etc/sysconfig/network?
08:00 AM
Aaron Bylund and Luis Lepe are now connections 07:51 AM
Peter Baldwin replied to the topic Re:6.6 final X server problem in the forums.
Hello,

If you can get access via SSH, try putting the following in /etc/X11/xorg.conf.d/vm.conf

Code:

Section "Screen"
    Identifier    "Default Screen"
    Monitor        "Configured Monitor"
    Device        "Configured Video Device"
    DefaultDepth    24
    Subsection "Display"
        Depth       24
        Modes       "800x600" "640x480"
       EndSubsection
EndSection

07:48 AM
6 days ago
Ben Chambers replied to the topic Re:Is the .htaccess file running ? mod_rewrite directive issues in the forums.
If I recall correctly from helping someone this week with a similar issue, it is the '-FollowSymLink' that is causing you grief.

In flexshare, set "FollowSymLinks" to enabled and try again.

FYI - your /var/log/httpd/access_log would have pointed you in the right direction.

B.
10:15 AM
1 week ago
Peter Baldwin replied to the topic Re:PHP openldap_directory warnings from app-samba-core update 1.6.8-1.v6 in the forums.
Hi Tony,

The error is triggered by a Samba SID cleanup script. In this particular case, it's harmless but I would still like to get to the bottom of it. Could you create the following test script (e.g. in /tmp/mytest.php):

Code:


#!/usr/clearos/sandbox/usr/bin/php
<?php

///////////////////////////////////////////////////////////////////////////////
// B O O T S T R A P
///////////////////////////////////////////////////////////////////////////////

$bootstrap = getenv('CLEAROS_BOOTSTRAP') ? getenv('CLEAROS_BOOTSTRAP') : '/usr/clearos/framework/shared';
require_once $bootstrap . '/bootstrap.php';

///////////////////////////////////////////////////////////////////////////////
// D E P E N D E N C I E S
///////////////////////////////////////////////////////////////////////////////

use \clearos\apps\groups\Group_Manager_Factory as Group_Manager_Factory;
use \clearos\apps\groups\Group_Engine as Group_Engine;

clearos_load_library('groups/Group_Manager_Factory');
clearos_load_library('groups/Group_Engine');

///////////////////////////////////////////////////////////////////////////////
// M A I N
///////////////////////////////////////////////////////////////////////////////

$group_manager = Group_Manager_Factory::create();
$details = $group_manager->get_details(Group_Engine::FILTER_ALL);
print_r($details);



Then run the script:

chmod 755 /tmp/mytest.php
/tmp/mytest.php

Do you seen any of the groups listed in the output without a "members" list? An empty list is fine, I'm looking for a group that doesn't have "members" defined at all.
Feb 26
Peter Baldwin replied to the topic Re:Serviio 1.5.1 on its way in the forums.
Many thanks Fred! FYI: Fred also provided us with updated ffmpeg and x265 RPM spec files. I have been able to get a variant built in our development (mock) environment, so we should be able to get things going through the build system soon.
Feb 26
Peter Baldwin, Ben Chambers replied to the topic Re:Kernel Panic after automatic update in the forums.
The 2.6.32-431 series (RHEL6.5) was not the best kernel series. We held it back on the Professional Edition for quite some time and ended up supplementing it with newer drivers. The 2.6.32-504 series (RHEL 6.6) seems to be much much better so far.
Feb 26
Peter Baldwin replied to the topic Re: Can't install kernel source for COS 6.5 2.6.32-431.1.2.v6.x86_64 in the forums.
For now, I have uploaded all the kernels to clearos7.clearfoundation.com/kernels/ The debug/debuginfo packages are excluded to save disk space, but are available if needed.
Feb 25
Peter Baldwin replied to the topic Re:6.6 Torrents not working and link wrong in the forums.
There was an issue getting the seed going at Terasaur. I'll see if I can get it working today.
Feb 25
Peter Baldwin replied to the topic Re:ClearOS will not automatically update Java in the forums.
Confirmed. The Software Updates app does not parse the package name properly.

Tracker: tracker.clearfoundation.com/view.php?id=2220
Github fix: github.com/clearos/app-software-updates/...8fd730c14b2202811bcf
Build info: buildsys.clearfoundation.com/plague/job.psp?uid=4985

The update should be hitting the mirrors in a few hours.
Feb 24
Ben Chambers replied to the topic Re:Let's Encrypt project in the forums.
Hi Jared,

Certainly does look interesting...Marc actually referenced this in a feature tracker...see here.

B
Feb 23
Ben Chambers replied to the topic Re: System won't update in the forums.
In cases like this, I'd recommend one of the following:

1. Upgrade broken dependencies first, then full update. In your case:

Code:

yum --enablerepo=clearos-core,clearos-contribs upgrade hal* libvirt*



Followed by:
Code:

yum upgrade



2. Upgrade using --skip-broken

Code:

yum --skip-broken upgrade



Though, #2 won't won't solve your issue going forward until you do something (upgrade, remove packages etc.).

B.
Feb 23
Ben Chambers replied to the topic Re:Clear OS 6.6 Professional Release Announcement in the forums.
Hi David,

Message received!

There's a lot of things we could have done better, and communication as you've mentioned, is so critical to those on the receiving end.

We didn't actively push out any notifications through the myriad of social tools available today. Our bad for keeping you guys in the dark.

6.6 was a strange release in that it overlapped with the v7 beta and resources being allocated for the new 'unified website' for ClearOS. Not an excuse...just a perfect storm.

B.
Feb 23
Peter Baldwin replied to the topic Re: Attn Mods - Forum Spam can I help? in the forums.
Yes, any help will be appreciated! We're in the final stages of prepping the new web site, but I'll get the ball rolling on the current web site.

More to come (heading out the door right now).
Feb 21
Peter Baldwin replied to the topic Re: ClearOS 6.6.0 breaking mail subsystem in the forums.
Hi Nick,

1777 should be the permissions for both /tmp and /var/tmp. Over the years, I have seen "spontaneous" permission changes on /tmp (on vanilla CentOS). It's probably some update script buried somewhere in an RPM doing something like "chmod 755 /tmp/$my_variable_filename" but "$my_variable_filename" is empty. That's speculation though.
Feb 21
2 weeks ago
Peter Baldwin replied to the topic Re:OpenLDAP not starting anymore today on several systems in the forums.
Here's more information on the crappy 6.6.0 update.

OpenLDAP upgrade

The underlying OpenLDAP engine was upgraded from 2.4.23 to 2.4.39. Inside the OpenLDAP RPM, there's an upgrade script that converts the existing LDAP database to the new version. The good news is that the upgrade works. The bad news is that in some circumstances (which we haven't determined), files in /var/lib/ldap are left with incorrect permissions and LDAP will refuse to start. In ClearOS 5, the startup script would automatically fix these permissions issues -- we ported that feature to ClearOS 6. That update will be hitting the repos shortly. In the meantime, you can run:

Code:

chown -R ldap.ldap /var/lib/ldap 
service slapd restart
service nslcd restart
service nscd restart



Network API and LDAP

In a bid to get rid of some duplicate code, the OpenLDAP startup script started using the Network API. If you had all of the following configured, the LDAP server would refuse to start:

- The network running in Standalone Mode (Standalone - No Firewall is not affected)
- Both an External and LAN interface defined
- The Directory Server configured to allow connections from the LAN (default is localhost only)

The quick workaround: go to "Server -> Directory Server" in the menu and set the Publish Policy to either i) Not Published (localhost) or ii) All Networks

The update to resolve this issue is also on its way to the repos.

Network Vendor Info

The network vendor information detection was also causing some parsing grief. This update was already pushed to the repos and is available.
Feb 20

Wall

No wall post to show

My Forum Updates

Groups

Here is a short listing of the groups that the user has registered in.